Page 1 of 1

Wireless telnet login

Posted: Sat Dec 18, 2010 11:31 pm
by procrastineer
I'm having trouble login to the router through telnet via my wireless network. I can login using a direct LAN connection (ethernet cable to LAN1) to the router. WL-520gU router ip address is 192.168.1.1. I haven't tried SSH and haven't set a root password.

I have followed the parts of the tutorial to do with the router setup including updates in part 8 and 9. I downloaded the precompiled firmware from the tutorial. The 'Air" LED is on the router, however my macbook can't find the ssid of the router.

My home modem/wireless router ip address is on 192.168.2.1 with DHCP starting on 192.168.2.150.

Here is my current configuration:

/etc/config/network

Code: Select all

#### VLAN configuration
config switch eth0
        option vlan0    "1 2 3 4 5*"
        option vlan1    "0 5"


#### Loopback configuration
config interface loopback
        option ifname   "lo"
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0


#### LAN configuration
config interface lan
        #option type    bridge
        option ifname "eth0.0"
        option proto    static
        option ipaddr   192.168.1.1
        option netmask  255.255.255.0

#### WAN configuration
config interface        wan
        option ifname   "eth0.1"
        option proto    dhcp
/etc/config/wireless

Code: Select all

config wifi-device  wl0
        option type     broadcom
        option channel  2

        # REMOVE THIS LINE TO ENABLE WIFI:


config wifi-iface
        option device   wl0
        option network  wan
        option mode     sta
        option ssid     linksys
        option encryption wep
        option key      xxxxxxxxxx


/etc/config/firewall

Code: Select all

config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT

config zone
        option name             lan
        option input    ACCEPT
        option output   ACCEPT
        option forward  REJECT

config zone
        option name             wan
        option input    ACCEPT
        option output   ACCEPT
        option forward  REJECT
        option masq             1

config forwarding
        option src      lan
        option dest     wan

### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# include a file with users custom iptables rules
#config include
#       option path /etc/firewall.user


### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp

Re: Wireless telnet login

Posted: Mon Dec 20, 2010 10:17 am
by mightyohm
A couple things that should help:

1. The router won't show up as a separate SSID. It is connecting as a client to your existing wireless network. Since the AIR light is on, this appears to be working.

2. Since the router is configured to use DHCP, your home wireless network will assign it an IP address of the form 192.168.2.x. x will be larger than 150, but you will need to determine the actual IP address. The 192.168.1.1 IP only works on the LAN side of the router, the WAN side gets an IP from your home network, and this is the IP you need if you want to telnet over wireless.

You can determine the IP address in one of several ways:

- Start at .150 and work your way up until you find it, ie. 192.168.2.150, 192.168.2.151, etc. Tedious. :D

- Go into your home wireless router's admin screen and see if you can find a list of DHCP clients, I think most routers will give you this. It will probably show the MAC address of each client, find the one that matches the MAC address sticker on the WL-520gU. Then note the IP address and try telnetting to that one over the wireless network.

- Telnet to the router via an ethernet cable on a LAN port (to 192.168.1.1) and run "ifconfig", this should list all network interfaces and the IP addresses for each. Take note of the IP address for the wireless interface (wl0 I think?), which hopefully is something like 192.168.2.x.

Ideally you would create a static IP for the wl-520 so that it always shows up as the same IP. dd-wrt lets you do this in a couple ways. I use dnsmasq so that the router always shows up as hostname "router" on the network. Then I can telnet or ping "router" and don't even need to know the IP.

Re: Wireless telnet login

Posted: Sat Dec 25, 2010 4:41 am
by procrastineer
Thank for replying.

I mistakenly thought that LAN and wireless network IP address is the same. Now I'm able to telnet over wireless network.

Follow up question: when connected via the LAN cable and using telnet with ip address 192.168.1.1 is the WL-520gU acting as the host (i.e. macbook is connecting as a client)?

Re: Wireless telnet login

Posted: Sun Dec 26, 2010 2:43 pm
by mightyohm
Yes, the router is the host and the macbook is the client.

The router is set up to handle two networks. On one network (the WAN side), it functions as a client on your existing wireless network. On the other network (the LAN side), it sits on 192.168.1.1 and accepts connections from other devices with static IP addresses connected to the LAN ethernet ports. There are other possibilities but this one was the easiest to set up given the default configuration files that come with OpenWrt.