Problem with telnet
Posted: Sun Nov 28, 2010 1:53 pm
hi all,
I have a problem:
When I telnet the router via the LAN1, then it seems that the router has problems with connection to the wifi -network. So I can’t play any music. The airlight is on continously but when I ask for the status in mpd, it reports that it has troubles opening the http-adress.
My settings are:
network
#### LAN configuration
config interface lan
#option type bridge
option ifname “eth0.0″
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
#### WAN configuration
config interface wan
option ifname “eth0.1″
option proto dhcp
wireless
config wifi-device wl10
option type broadcom
option channel 11
config wifi-iface
option device wl10
option network wan
option mode sta
option ssid netgear
option encryption psk
option key XXXXXXXX
firewall
config zone
option name wan
option input ACCEPT
option output ACCEPT
option forward REJECT
option masq 1
When I change the network settings to:
config interface lan
option type bridge
option ifname “eth0.0″
option proto dhcp
#option ipaddr 192.168.1.1
#option netmask 255.255.255.0
then I can’t telnet but I can play music via the terminal and everyhing seems to work fine
Any ideas on how to make it work via telnet?
I have a problem:
When I telnet the router via the LAN1, then it seems that the router has problems with connection to the wifi -network. So I can’t play any music. The airlight is on continously but when I ask for the status in mpd, it reports that it has troubles opening the http-adress.
My settings are:
network
#### LAN configuration
config interface lan
#option type bridge
option ifname “eth0.0″
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
#### WAN configuration
config interface wan
option ifname “eth0.1″
option proto dhcp
wireless
config wifi-device wl10
option type broadcom
option channel 11
config wifi-iface
option device wl10
option network wan
option mode sta
option ssid netgear
option encryption psk
option key XXXXXXXX
firewall
config zone
option name wan
option input ACCEPT
option output ACCEPT
option forward REJECT
option masq 1
When I change the network settings to:
config interface lan
option type bridge
option ifname “eth0.0″
option proto dhcp
#option ipaddr 192.168.1.1
#option netmask 255.255.255.0
then I can’t telnet but I can play music via the terminal and everyhing seems to work fine
Any ideas on how to make it work via telnet?