Well, like many I did a variation of this project. Seemingly everything was working fine. I was, however, having some network issues that I mistakenly thought were unrelated. I checked and re-checked the various config files and can't seem to find the problem. My wl-520 is not acting as a station, but appears to be acting as a wireless access point. In addition, it is using the SSID as my real access point. As I said, have look over the config files many times. I have restarted the router many times, but no success. Any one have any suggestions?
Thanks
Wireless configuration - Not access point
Re: Wireless configuration - Not access point
Please post the contents of your /etc/config/network and /etc/config/wireless configuration files.
Jeff Keyzer
http://mightyohm.com
http://mightyohm.com
Re: Wireless configuration - Not access point
For the most part, everything appeared to work fine. I could ssh in over the wireless, or I could connect via a hard wire. The device could talk to other boxes and get the music to be played. At some point I noticed my DSL line was not giving me the speed I should be getting. Eventually, I discovered the my asus was acting as an access point and not a station.
When I set about doing this, I had decided that I did not want to do the serial port thing and therefore would need to be able to ssh in. Ideally, I would like it to provide access to the internet on the LAN ports. This is how it is working now, but it appears that the device ignores the "sta" directive.
Thanks
network config
wireless config
When I set about doing this, I had decided that I did not want to do the serial port thing and therefore would need to be able to ssh in. Ideally, I would like it to provide access to the internet on the LAN ports. This is how it is working now, but it appears that the device ignores the "sta" directive.
Thanks
network config
Code: Select all
#### VLAN configuration
config switch eth0
option vlan0 "0 1 2 3 5*"
option vlan1 "4 5"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 192.168.1.4
option netmask 255.255.255.0
option gateway 192.168.1.128
option dns 208.65.88.2 208.65.88.1
#### WAN configuration
config interface wan
option ifname "eth0.1"
option proto static
option ipaddr 192.168.2.1
option netmask 255.255.255.0
option dns 208.65.88.2 208.65.88.1
wireless config
Code: Select all
config wifi-device wl0
option type broadcom
option channel 6
# REMOVE THIS LINE TO ENABLE WIFI:
config wifi-iface
option device wl0
option network wan
option mode sta
option ssid my_ssid
option encryption none
Re: Wireless configuration - Not access point
How can you tell the router is functioning as an AP? Do you actually see it show up with it's own SSID when you browse for wireless networks from another device?
Your /etc/config/wireless looks good, assuming you replace my_ssid with the SSID of your wireless network and make sure that you are using Wi-Fi channel 6.
However, I see some potential issues with your /etc/config/network configuration.
First, your VLAN configuration doesn't match the default (or my config). I don't think this is necessarily a problem, but why did you choose to swap ports 0 and 4 in the VLAN config? If I understand VLAN correctly, this has the effect of changing the WAN ethernet port from port 0 (the one marked WAN on the case) to port 4 (the port marked LAN4).
Second, you are configuring a static IP and DNS servers for the WAN/wireless interface. Make sure that your home wireless network allows this, and that the subnet is correct. If this information is incorrect, the router will not connect as a client on your wireless network.
Third, you have your LAN interface set to bridge to your WAN interface, yet you have different IP addresses and subnets configured for each interface. I don't think this will work. You need to either leave bridging enabled and enable dhcp on the LAN ports so that you can use the LAN ports to access the network, or disable bridging so that you can use the LAN ports to ssh into the router. I'm not sure how to configure the router to do both simultaneously. I would see if you can get a non-bridged configuration to work first by commenting out the "option type", "option gateway" and "option dns" entries of the LAN config. You should then be able to ssh into the router at 192.168.1.4, assuming that IP isn't in the same subnet as your home network. If it is, change it to another subnet.
It's possible that OpenWrt is rejecting your settings and refusing to enter client mode. This might be why it's showing up as an AP instead.
Your /etc/config/wireless looks good, assuming you replace my_ssid with the SSID of your wireless network and make sure that you are using Wi-Fi channel 6.
However, I see some potential issues with your /etc/config/network configuration.
First, your VLAN configuration doesn't match the default (or my config). I don't think this is necessarily a problem, but why did you choose to swap ports 0 and 4 in the VLAN config? If I understand VLAN correctly, this has the effect of changing the WAN ethernet port from port 0 (the one marked WAN on the case) to port 4 (the port marked LAN4).
Second, you are configuring a static IP and DNS servers for the WAN/wireless interface. Make sure that your home wireless network allows this, and that the subnet is correct. If this information is incorrect, the router will not connect as a client on your wireless network.
Third, you have your LAN interface set to bridge to your WAN interface, yet you have different IP addresses and subnets configured for each interface. I don't think this will work. You need to either leave bridging enabled and enable dhcp on the LAN ports so that you can use the LAN ports to access the network, or disable bridging so that you can use the LAN ports to ssh into the router. I'm not sure how to configure the router to do both simultaneously. I would see if you can get a non-bridged configuration to work first by commenting out the "option type", "option gateway" and "option dns" entries of the LAN config. You should then be able to ssh into the router at 192.168.1.4, assuming that IP isn't in the same subnet as your home network. If it is, change it to another subnet.
It's possible that OpenWrt is rejecting your settings and refusing to enter client mode. This might be why it's showing up as an AP instead.
Jeff Keyzer
http://mightyohm.com
http://mightyohm.com
Re: Wireless configuration - Not access point
Yes, it shows up as another AP with the same SSID as my real AP.mightyohm wrote:How can you tell the router is functioning as an AP? Do you actually see it show up with it's own SSID when you browse for wireless networks from another device?
Yeap, Wi-Fi is on channel 6 and I did use my real ssid.mightyohm wrote:Your /etc/config/wireless looks good, assuming you replace my_ssid with the SSID of your wireless network and make sure that you are using Wi-Fi channel 6.
Not sure why I did this. My have gotten this from googling around.mightyohm wrote:However, I see some potential issues with your /etc/config/network configuration.
First, your VLAN configuration doesn't match the default (or my config). I don't think this is necessarily a problem, but why did you choose to swap ports 0 and 4 in the VLAN config? If I understand VLAN correctly, this has the effect of changing the WAN ethernet port from port 0 (the one marked WAN on the case) to port 4 (the port marked LAN4).
Yes, I use static ips for my network and it works. The subnet is the subnet that my home network uses as are the DNS servers.mightyohm wrote:Second, you are configuring a static IP and DNS servers for the WAN/wireless interface. Make sure that your home wireless network allows this, and that the subnet is correct. If this information is incorrect, the router will not connect as a client on your wireless network.
192.168.1.4 is the ip address I want the device to use to access my wireless network. If I use a non-bridged configuration, I should be able to access the ASUS by sshing into 192.168.1.4, correct? Ideally, this is what I want. The ability to connect via hardwire is not needed if I can get the wireless to work.mightyohm wrote:Third, you have your LAN interface set to bridge to your WAN interface, yet you have different IP addresses and subnets configured for each interface. I don't think this will work. You need to either leave bridging enabled and enable dhcp on the LAN ports so that you can use the LAN ports to access the network, or disable bridging so that you can use the LAN ports to ssh into the router. I'm not sure how to configure the router to do both simultaneously. I would see if you can get a non-bridged configuration to work first by commenting out the "option type", "option gateway" and "option dns" entries of the LAN config. You should then be able to ssh into the router at 192.168.1.4, assuming that IP isn't in the same subnet as your home network. If it is, change it to another subnet.
I think you ended with the configuration that I want or that will work for me. I will review your config files and start over again.mightyohm wrote:It's possible that OpenWrt is rejecting your settings and refusing to enter client mode. This might be why it's showing up as an AP instead.
Thanks
Re: Wireless configuration - Not access point
The router will show up on your wireless network using the WAN address you have set (192.168.2.1). You should be able to ssh in over the wireless if you made the firewall changes I talk about in part 9 of the Wifi Radio tutorial (http://www.mightyohm.com/blog/2009/05/b ... -and-ends/).
If you set up the LAN ports as I mentioned above, you'll also be able to ssh into the router via an ethernet cable by using whatever address you configure for the LAN, in your case 192.168.1.4. I have only tested 192.168.1.1, there may be some issues changing the LAN IP - if 192.168.1.4 doesn't work, try 192.168.1.1 instead. I like to have this ability in case something goes wrong with the Wi-Fi and I need an alternate way into the router.
If you set up the LAN ports as I mentioned above, you'll also be able to ssh into the router via an ethernet cable by using whatever address you configure for the LAN, in your case 192.168.1.4. I have only tested 192.168.1.1, there may be some issues changing the LAN IP - if 192.168.1.4 doesn't work, try 192.168.1.1 instead. I like to have this ability in case something goes wrong with the Wi-Fi and I need an alternate way into the router.
Jeff Keyzer
http://mightyohm.com
http://mightyohm.com