Search found 4 matches

by luchenbe
Tue May 11, 2021 3:47 am
Forum: Geiger Counter
Topic: Serial Console giving scrambled output like "IKL\0xe9\0xd4!/%\0xa39!%" - SOLVED
Replies: 10
Views: 17088

Re: Serial Console giving scrambled output like "IKL\0xe9\0xd4!/%\0xa39!%" - SOLVED

I build the complete kit from Elektor. Are there any updates in the firmware since then? Can a newer software version be flashed to the microcontroller? About the serial interface problem: in the mean time I interfaced the Geiger counter to my portable PC via an Arduino Mega2560 and that works fine....
by luchenbe
Fri May 07, 2021 3:27 am
Forum: Geiger Counter
Topic: Serial Console giving scrambled output like "IKL\0xe9\0xd4!/%\0xa39!%" - SOLVED
Replies: 10
Views: 17088

Re: Serial Console giving scrambled output like "IKL\0xe9\0xd4!/%\0xa39!%" - SOLVED

I tested it again on an old Windows XP PC with a real serial port and it's exactly the same again. I then used the USB-serial adapter on that same PC and it gave exactly the same output... It has to be some problem with the serial output of the ATtiny.
by luchenbe
Thu May 06, 2021 11:44 am
Forum: Geiger Counter
Topic: Serial Console giving scrambled output like "IKL\0xe9\0xd4!/%\0xa39!%" - SOLVED
Replies: 10
Views: 17088

Re: Serial Console giving scrambled output like "IKL\0xe9\0xd4!/%\0xa39!%" - SOLVED

It's a HAMA 00053325V2 but that's not the cause as I have exactly the same problem with an old Win98 laptop with a real serial port. I have also an old WinXP PC in my workshop on which I can test this tomorrow, but I don't think it will work either. In the mean time I checked the ceramic resonator b...
by luchenbe
Wed May 05, 2021 12:21 pm
Forum: Geiger Counter
Topic: Serial Console giving scrambled output like "IKL\0xe9\0xd4!/%\0xa39!%" - SOLVED
Replies: 10
Views: 17088

Re: Serial Console giving scrambled output like "IKL\0xe9\0xd4!/%\0xa39!%" - SOLVED

I have exactly the same problem with both a Windows 10 computer with a USB-serial adapter and with a very old Windows 98 portable PC with hyperterminal on a hardware serial port. Both serial connection work flawlessly with other applications. Whatever I do, I get on both exactly the same unreadable ...