WL-520gU openWRT failsafe mode?

Discussion about my Wifi Radio project at http://mightyohm.com/wifiradio/ or my WL-520gU talk at NOTACON.

WL-520gU openWRT failsafe mode?

Postby nhbubba » Thu Mar 25, 2010 9:36 am

So what do we know about the openWRT failsafe mode on the WL-520gU?

I was following the network setup procedure outlined in step 4 of mightyohm's guide. I got a little too cocky and changed all the configs at once, then threw the /etc/init.d/network restart switch. Now my router seems deaf! I cannot ping it nor does the AIR indicator light up. It does not seem to be on my wireless 'net.

I followed the suggestions here. I see the "Press reset now, to enter Failsafe!" message when running nc ("nc -lu 4919" seems to be the syntax on the MAC btw). That I see the message gives me confidence that the router is booting okay. I press the reset button for 2-seconds and get nothing. After holding for ~10 sec the power light goes out and eventually back on, but I cannot ping or telnet to it at 192.168.1.1, which the docs say it should default to.

I guess my next option is to wire it into my home 'net and see if it grabs a dhcp lease, then connect to it that way.

Unfortunately do not have a TTL level serial adapter. (It has been ordered.)

Edit: I should add I am running might's canned 2.4 kamikaze image, r12857 I think.
nhbubba
 
Posts: 7
Joined: Wed Mar 24, 2010 6:10 am
Location: Southern NH

Re: WL-520gU openWRT failsafe mode?

Postby jeroen94704 » Fri Mar 26, 2010 1:19 pm

You may have simply disabled the wireless radio (the "air" light not coming on is a clue ;) ). Attach it to your wired network, and see if you can ping it from there.

If everything fails, you'll have to reflash. If it makes you feel better, I must've reflashed my mpd-box a dozen times before getting it right.

Jeroen
jeroen94704
 
Posts: 109
Joined: Sat Feb 13, 2010 4:27 am
Location: Eindhoven, the Netherlands

Re: WL-520gU openWRT failsafe mode?

Postby nhbubba » Mon Mar 29, 2010 3:55 am

I fixed my problem, however I am still not able to get 'failsafe' mode to work.

In my case I simply connected my WL-520gU to my wired home network. My (real) router (in the basement) gave it an IP. I was able to look at the host tables on the router and figure out what IP it went to. I then telnet'ed in and fixed my /etc/config/network and put eth0.0 back on a static IP.

I still can't get the wireless to link up. I swear it is enabled... but will look at that again. My home 'net is running WPA2. I thought I had read that there were issues getting the router to connect to a WPA2 'net in station mode?! Should I expect to see the AIR LED lit whenever the wifi radio is active, even if it hasn't got link?

Edit: this post says WPA2 should work. Hmph.. suggests my radio is in-fact disabled.
nhbubba
 
Posts: 7
Joined: Wed Mar 24, 2010 6:10 am
Location: Southern NH

Re: WL-520gU openWRT failsafe mode?

Postby mightyohm » Tue Mar 30, 2010 9:44 am

Once you get console access to the router, post your config files here and we can take a look at them together.

Useful stuff:
dmesg output
/etc/config/network
/etc/config/wireless
/etc/config/firewall
User avatar
mightyohm
Site Admin
 
Posts: 843
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA


Return to Wifi Radio Project / Hacking the Asus WL-520gU

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron