Wireless SSH or Telnet login.

Discussion about my Wifi Radio project at http://mightyohm.com/wifiradio/ or my WL-520gU talk at NOTACON.
Post Reply
User avatar
Silent-Hunter
Posts: 16
Joined: Fri Feb 26, 2010 10:11 pm

Wireless SSH or Telnet login.

Post by Silent-Hunter »

Is there a way to login to the router through SSH or Telnet via my wireless network? If not, why?
User avatar
mightyohm
Site Admin
Posts: 1064
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Wireless SSH or Telnet login.

Post by mightyohm »

Yes, you can do this. You need to know the IP address of the router, and the firewall and network configuraton on the router needs to be set correctly. If you use the settings given in the tutorial (including the updates in part 8 or 9) then you should be able to telnet/ssh to the router over wifi. I do this regularly and haven't used an Ethernet cable in several months.
User avatar
Silent-Hunter
Posts: 16
Joined: Fri Feb 26, 2010 10:11 pm

Re: Wireless SSH or Telnet login.

Post by Silent-Hunter »

It won't work for me. My network uses 192.168.0.1 as gateway.
User avatar
mightyohm
Site Admin
Posts: 1064
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Wireless SSH or Telnet login.

Post by mightyohm »

I need more information to help you.

Do you know what IP address your router is using? Can you log in using a direct LAN connection to the router? Are you using ssh or telnet? Did you set a root password?

Please post your /etc/config/network, /etc/config/wireless, and /etc/config/firewall files.

How far have you made it thru the wifi radio tutorials, if you are following them?

Are you using the firmware I posted in the tutorials or something else?
User avatar
Silent-Hunter
Posts: 16
Joined: Fri Feb 26, 2010 10:11 pm

Re: Wireless SSH or Telnet login.

Post by Silent-Hunter »

Well, I tried a few different ones. I tried 192.168.0.101 and 192.168.0.111 and neither worked. It wouldn't let me connect to the internet when I did that. I can log into the router directly, but only with a 192.168.1.XXX address, not a 192.168.0.XXX one, which is what my wireless network uses. I'll post the contents of those three files tomorrow, it's very late for me, 1:24 am. I have made it to the part where the router will play music. I plan to finish with the screen and dial part later. In the mean time, I want to be able to control it from my laptop.
richms
Posts: 21
Joined: Fri Jul 24, 2009 3:25 am

Re: Wireless SSH or Telnet login.

Post by richms »

I dont use either of those ranges, and following the tutorial the asus got assigned an IP off my network and was accessible via that IP.

Check your DHCP server log or status page to see what IP the asus has been assigned.
User avatar
Silent-Hunter
Posts: 16
Joined: Fri Feb 26, 2010 10:11 pm

Re: Wireless SSH or Telnet login.

Post by Silent-Hunter »

Well, I changed some settings, and now it actually tries to connect, but PuTTY says "no route to host".

/etc/config/wireless:

Code: Select all

config wifi-device  wl0
        option type     broadcom
        option channel  5

        # REMOVE THIS LINE TO ENABLE WIFI:
        # option disabled 1

config wifi-iface
        option device   wl0
        option network  wan
        option mode     sta
        option ssid     dlink
        option encryption wep
        option key 060288ADA0
/etc/config/network:

Code: Select all

#### VLAN configuration             
config switch eth0                  
        option vlan0    "1 2 3 4 5*"
        option vlan1    "0 5"
                            
                              
#### Loopback configuration         
config interface loopback    
        option ifname   "lo"
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0
                                 
                                 
#### LAN configuration           
config interface lan             
        #option type    bridge
        option ifname   "eth0.0"
        option proto    static  
        option ipaddr   192.168.0.101
        option netmask  255.255.255.0
                                     
                                     
#### WAN configuration               
config interface        wan          
        option ifname   "eth0.1"
        option proto    dhcp   
/etc/config/firewall:

Code: Select all

config defaults                                  
        option syn_flood        1                
        option input            ACCEPT           
        option output           ACCEPT           
        option forward          REJECT           
                                                 
config zone                                      
        option name             lan              
        option input    ACCEPT                   
        option output   ACCEPT                   
        option forward  REJECT                   
                                                 
config zone                                      
        option name             wan              
        option input    ACCEPT                   
        option output   ACCEPT                   
        option forward  REJECT         
        option masq             1                
                                                 
config forwarding                                
        option src      lan                      
        option dest     wan                      
                                                 
                                                 
### EXAMPLE CONFIG SECTIONS                      
# do not allow a specific ip to access wan       
#config rule                                     
#       option src              lan              
#       option src_ip   192.168.45.2             
#       option dest             wan              
#       option proto    tcp                      
#       option target   REJECT                   
                                                 
# block a specific mac on wan                    
#config rule                                     
#       option dest             wan              
#       option src_mac  00:11:22:33:44:66        
#       option target   REJECT                   
                                                 
# block incoming ICMP traffic on a zone
#config rule                                     
#       option dest             wan              
#       option src_mac  00:11:22:33:44:66        
#       option target   REJECT                   
                                                 
# block incoming ICMP traffic on a zone          
#config rule                                     
#       option src              lan              
#       option proto    ICMP                     
#       option target   DROP                     
                                                 
# port redirect port coming in on wan to lan     
#config redirect                                 
#       option src                      wan      
#       option src_dport        80               
#       option dest                     lan      
#       option dest_ip          192.168.16.235   
#       option dest_port        80               
#       option proto            tcp              
                                                 
# include a file with users custom iptables rules
#config include                                  
#       option path /etc/firewall.user                                                    
                                                 
### FULL CONFIG SECTIONS                         
#config rule                                     
#       option src              lan              
#       option src_ip   192.168.45.2             
#       option src_mac  00:11:22:33:44:55        
#       option src_port 80                       
#       option dest             wan              
#       option dest_ip  194.25.2.129             
#       option dest_port        120              
#       option proto    tcp                      
#       option target   REJECT                   
                                                 
#config redirect                                 
#       option src              lan              
#       option src_ip   192.168.45.2          
#       option src_mac  00:11:22:33:44:55        
#       option src_port         1024             
#       option src_dport        80               
#       option dest_ip  194.25.2.129             
#       option dest_port        120              
#       option proto    tcp        
/etc/resolv.conf:

Code: Select all

nameserver 127.0.0.1
User avatar
Silent-Hunter
Posts: 16
Joined: Fri Feb 26, 2010 10:11 pm

Re: Wireless SSH or Telnet login.

Post by Silent-Hunter »

Also, when I turn off the router, it loses all my added radio stations.
User avatar
Silent-Hunter
Posts: 16
Joined: Fri Feb 26, 2010 10:11 pm

Re: Wireless SSH or Telnet login.

Post by Silent-Hunter »

The wireless is actually working now, but I still have the weird not keeping the radio stations problem.
Post Reply