Troubles with ATtiny85 fuses = 0xFF

Topics related to the HV Rescue Shield:
http://mightyohm.com/hvrescue2
User avatar
mightyohm
Site Admin
Posts: 1004
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Troubles with ATtiny85 fuses = 0xFF

Post by mightyohm » Wed Dec 02, 2015 7:03 pm

Can you explain what you mean by "Then I am put it in socket and try to re-burn"?

dale
Posts: 7
Joined: Wed Nov 25, 2015 8:19 am

Re: Troubles with ATtiny85 fuses = 0xFF

Post by dale » Thu Dec 03, 2015 9:47 am

I mean I am not remove the 328p form socket, then press the button to read the fuse again.

User avatar
mightyohm
Site Admin
Posts: 1004
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Troubles with ATtiny85 fuses = 0xFF

Post by mightyohm » Thu Dec 03, 2015 10:19 am

You need to remove the 328P from the socket between fuse writing operations. Can you try removing it from the socket before you attempt to burn the fuses again?

dale
Posts: 7
Joined: Wed Nov 25, 2015 8:19 am

Re: Troubles with ATtiny85 fuses = 0xFF

Post by dale » Thu Dec 03, 2015 9:37 pm

I have to do it according to your step, but fuse always is 0xFF when first read. maybe these 328P are damage?

User avatar
mightyohm
Site Admin
Posts: 1004
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Troubles with ATtiny85 fuses = 0xFF

Post by mightyohm » Thu Dec 03, 2015 11:27 pm

That is strange. Do you have another 328p you can try?

dale
Posts: 7
Joined: Wed Nov 25, 2015 8:19 am

Re: Troubles with ATtiny85 fuses = 0xFF

Post by dale » Fri Dec 04, 2015 8:37 am

I just have two 328P of DIP package now, when I get new 328P, I will try it again.

User avatar
mightyohm
Site Admin
Posts: 1004
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Troubles with ATtiny85 fuses = 0xFF

Post by mightyohm » Sun Dec 13, 2015 4:41 pm

OK, please post any updates.

dale
Posts: 7
Joined: Wed Nov 25, 2015 8:19 am

Re: Troubles with ATtiny85 fuses = 0xFF

Post by dale » Fri Jan 01, 2016 1:58 am

Hi mightyohm,

I got new 328P, and it always have error, so I trace the PCB,
then find a trace not connect to 328P pin15, so it read/write has error.

This is my problem, because this PCB is make by me.

Thanks your help.

User avatar
mightyohm
Site Admin
Posts: 1004
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Troubles with ATtiny85 fuses = 0xFF

Post by mightyohm » Fri Jan 01, 2016 12:07 pm

glad to hear you got it sorted out! :ugeek:

Post Reply