USB device not accepting new address

Discussion about my Wifi Radio project at or my WL-520gU talk at NOTACON.
Posts: 1
Joined: Mon May 16, 2011 8:11 am

USB device not accepting new address

Postby pbeesley » Sun Aug 30, 2015 8:44 pm

Everything was going well (Music playing and LCD display functioning) until...
I desoldered my power, USB header and sound card USB as displayed int he images in step 10 and I am now I'm getting an error connecting the usb sound card.
On boot the error messages are displayed below. I'm using a Asus WL520GU and the SYBA USB sound card.
I have tried reimaging the router with OpenWRT (the image provided on Jeff's instructions)
I tested the USB sound card in a different computer see if it works and it does.
I thought maybe I fried something while desoldering but I get the same results on two different routers (both desoldered) and two different sound cards (also desoldered). I'm not a soldering expert but I took my time and the vias look good. I test for continuity and the connection appear to be good.
Any ideas on what I did wrong?

*** Edit, I'd also like to add I'm getting 4.7v between red and black on the USB sound card but no lights
usb-ohci.c: USB OHCI at membase 0xb8003000, IRQ 6
usb-ohci.c: usb-00:03.0, PCI device 14e4:471a
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
usb.c: registered new driver audio
audio.c: v1.0.0:USB Audio Class driver
hub.c: new USB device 00:03.0-1, assigned address 2
usb.c: USB device not accepting new address=2 (error=-145)
hub.c: new USB device 00:03.0-1, assigned address 3
usb.c: USB device not accepting new address=3 (error=-145)

Posts: 7
Joined: Fri Jul 26, 2019 12:44 pm
Location: Panama

USB device not accepting new address

Postby KamOffife » Sun Aug 04, 2019 3:14 am

I am trying to update the latest map. Both my Win 7 and Win XP laptops refuse to recognise the GPS attached to my USB cable.
I have tried two different USB cables on two different laptops running two versions of Windows.
I have also done a factory reset. Still no good.
I have done a map update before on my Win 7 laptop with no problems but not this time. I am not connecting through a hub - direct connection to a USB port. Getting exasperated now.
Anything else I can try?