Madplay installation

Discussion about my Wifi Radio project at http://mightyohm.com/wifiradio/ or my WL-520gU talk at NOTACON.
User avatar
gerben
Posts: 164
Joined: Sat Oct 16, 2010 8:41 am
Location: Netherlands

Re: Madplay installation

Post by gerben »

try putting the following in your rc.local

Code: Select all

(
  sleep 5
  while [ 1 ]
  do
     wget -O - http://89.238.227.6:8000/ | madplay -
     sleep 2
  done
)&

exit 0

claus14
Posts: 13
Joined: Tue Apr 09, 2013 5:08 pm

Re: Madplay installation

Post by claus14 »

Thank you Gerben. I changed the rc.local line with the ones you gave me and it works great. I'll give you more details, to explain what I did.
Ok, so I changed the lines in rc.local file, restarted the router and within approx. 30 seconds it started to play the webradio I selected. Later, I disconnected the network cable of the router (TP-Link) from the main router (Netgear), left it disconnected for about 20-30 seconds and then connected back. It started to play the radio station again, after about 30 seconds, like it did the first time. I only disconnected the ethernet cable, the power cable was connected all the time to all the equipment.
My settings are:

Modem>>>>>Netgear router (main router)>>>> TP-Link router (Openwrt router).

Saturday afternoon I wanted to connect the power cable of TP-Link router(openwrt router) to a different outlet and I accidentally disconnected the power cable of the modem. When I connected back the modem, it took a different IP address. It always does that, I have a dynamic IP address from my my internet provider. A few minutes later, I checked to see if the hacked router (TP-Link) plays music but at that moment it was not playing anything.
So, my fix was to unplug and then plug back the power to my TP-Link router and that fixed the sound issue.
These are my news.
So, in conclusion, If I disconnect only the network cable(the power cable is connected all the time) and then reconnect it back shortly after that, it runs the way it should, so is OK. I'll try these days to leave the network cable disconnected for a longer period, maybe an hour or two (of course, power cable will be connected all the time) and share the results with you.
Thank you, again. By the way, I just ordered another TL-WR703N from ebay and another brand of USB audio adapter(Syba), for the next project: I'd like to have a stand-alone radio in another bedroom. I'll update the results later.

Post Reply