No Wireless, No address

Discussion about my Wifi Radio project at http://mightyohm.com/wifiradio/ or my WL-520gU talk at NOTACON.
Post Reply
camac881
Posts: 1
Joined: Tue Jan 22, 2013 5:49 pm

No Wireless, No address

Post by camac881 »

Hi All,
Thanks for a great project, Jeff, and thanks for the help site. I have been looking for something like this for a long time.

This thing is confusing the heck out of me. I had no problem uploading the new code, but I cannot get it to take an address or connect the wireless. I have been through the topics here about the "Air" light not coming on, as mine does not either, and several other configuration topics. Still no cigar. My configuration is as follows;

Network Config

#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0


#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 192.168.8.30
option netmask 255.255.255.0
option gateway 192.168.8.1

#### WAN configuration
config interface wan
option ifname "eth0.1"
option proto dhcp

Wireless Config

config wifi-device wl0
option type broadcom
option channel 11 # The Channel your network is on

# REMOVE THIS LINE TO ENABLE WIFI:


config wifi-iface
option device wl0
option network lan
option mode sta # configures the router to connect to your network
option ssid 4DDF7 # SSID of your network
option encryption wep # Encryption mode of your network
option key xxxxxxxxxx # Add the network key (blanked for Blog)

Firewall Config

Vconfig defaults
option syn_flood 1
option input ACCEPT
option output ACCEPT
option forward REJECT

config zone
option name lan
option input ACCEPT
option output ACCEPT
option forward REJECT

config zone
option name wan
option input ACCEPT
option output ACCEPT
option forward REJECT
option masq 1

config forwarding
option src lan
option dest wan

I am green to Linux, but I have poked around enough to us vi and some simple file commands. I looked at the documentation at OpenWRT and BusyBox and I am no further ahead. Any help is appreciated. Thanks in advance!
User avatar
gerben
Posts: 164
Joined: Sat Oct 16, 2010 8:41 am
Location: Netherlands

Re: No Wireless, No address

Post by gerben »

Try disabling WEP. This makes finding the problem a bit easier. The only difference I can see is, that in my setup, I set the lan interface to DHCP. (I have setup static-dhcp on my dsl-router, so the Asus always has the same IP).
Post Reply