Ultra Noob Needs Help - MP3 folder

Discussion about my Wifi Radio project at http://mightyohm.com/wifiradio/ or my WL-520gU talk at NOTACON.
Post Reply
hernando
Posts: 5
Joined: Sun Dec 12, 2010 11:10 am

Ultra Noob Needs Help - MP3 folder

Post by hernando »

Hi Gang,

This has been a very exciting project for me. Thank you so much for your work!!

I have followed the directions on Tinkernut's video to the letter. For the most part, I believe I have been successful, except I get the beeping sound. I have ordered from eBay one of the Eupix 7.1 audio USB and I hope this solves my issue.

In the meantime, I also want to be able to play my library of mp3 files. My MP3 collection is stored on a Win 7 machine and I have used Hanewin NFS server to share the folder containing all my music. I don't know how I can get mpc to locate my music so it is always available. I suspect I have to edit the /etc/mpd.conf file and make the proper entry in the music_directory. But I simply cannot figure out what to enter here. My Win 7 machine is on ip 192.168.0.102 and the NFS share is /musica. I have made this folder -public and NOT readonly. My WL-520GU is on ip 192.168.0.88.

Any advice or guidance is greatly appreciated.

Many Thanks,

Hernando

jeroen94704
Posts: 109
Joined: Sat Feb 13, 2010 4:27 am
Location: Eindhoven, the Netherlands

Re: Ultra Noob Needs Help - MP3 folder

Post by jeroen94704 »

You must first mount the NFS share on a local directory. Teh command in your case would be something like:

Code: Select all

mount -t nfs 192.168.0.102:/music /remotemusic   
Where you have to make sure that the "/remotemusic" directory does exist on your wl-520.

From that point on, the NFS share can be accessed like any local directory, so you can simply use "/remotemusic" as you music dir in the mpd config file

Hope this helps,

Jeroen

hernando
Posts: 5
Joined: Sun Dec 12, 2010 11:10 am

Re: Ultra Noob Needs Help - MP3 folder

Post by hernando »

Thank you Jeroen!

Now I get it. I created the folder using the command "mkdir remotemusic". Then I typed the command:

Code: Select all

mount -t nfs 192.168.0.102:/musica /remotemusic
It took a few minutes but then it returned the following error; "mount: RPC: Timed out"

I read in other posts that I should use the portmap command before mounting. But when I type "portmap" I get "portmap not found". I tried typing "opkg install portmap" and it did not find the package. I searched the forum and found nothing on how to install portmap... I did use the firmware linked in the Tinkernut video.

I feel I am close....

Thanks again!!

User avatar
mightyohm
Site Admin
Posts: 1016
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: Ultra Noob Needs Help - MP3 folder

Post by mightyohm »

I think most of the guys playing with NFS here are running OpenWrt 8.09 or later... My 7.09 files don't include portmap, apparently...

Benco
Posts: 1
Joined: Fri Jan 31, 2014 7:47 pm

Re: Ultra Noob Needs Help - MP3 folder

Post by Benco »

Jeff thank you for this site and thank you for the time you spend doing this. Tinkernet project has lead me here... lol Better late than never I suppose. Making something do something it wasn't designed to do, and using ANY radio to accomplish the goal is quite ingenious. :-)

Jeroen and Hernando - I've been trying to do the same thing. Stream MP3's off my Asus. I'm digging for the answer just like you. Though, I do not have a solution, here are a couple of things to look at. I'm not an expert on this by any means. I don't know if this will work, but I think these are the the next steps where many have come to a road block.

Hernando, turn off your windows firewall on your internal network. The long pause before RPC fails is because of the firewall, yes, even inside your "home" network. Run the mount -t nfs and see how fast it errors out.

Secondly, instead of mount -t nfs use mount-t ntfs (if your drives are formatted in ntfs). I shared my music folder and set permissions to everyone full access within the share, and full access within NTFS. Yes, I've got very loose security going on when doing this, but it's to rule a bunch of things out until I see if this works the way I want it to. I'll tie up the loose ends later.

When you attempt the mount -t ntfs 192.168.xx.xx/share /music this won't work. Music is a folder not a device.

If you try:
root@OpenWrt:~# mount -t ntfs 192.168.1.100/MusicPC
mount: can't find 192.168.1.100/MusicPC in /etc/fstab

root@OpenWrt:/etc# cat fstab
# WARNING: this is an auto generated file, please use uci to set static filesystems
/dev/sda1 /home ext3 noauto,rw,sync 0 0

I don't know what fstab is (don't laugh) other than to mount a drive or folder, and not sure if there is enough available RAM on the Asus to handle it?? My next step is to check out - http://wiki.openwrt.org/doc/uci/fstab

I am running Asus WL-520GU Here is something else you may find interesting. Shows you how much room you have left, I think.

root@OpenWrt:~# df -h
Filesystem Size Used Available Use% Mounted on
rootfs 1.3M 1.3M 0 100% /
/dev/root 1.3M 1.3M 0 100% /rom
tmpfs 7.0M 44.0k 7.0M 1% /tmp
/dev/mtdblock/4 2.1M 976.0k 1.1M 46% /jffs
mini_fo:/jffs 1.3M 1.3M 0 100% /

I will look into this fstab and see what happens. It's late and I'm ready to crash. Maybe a linux guru on here can elaborate more?

Post Reply