interface.sh not starting at boot

Discussion about my Wifi Radio project at http://mightyohm.com/wifiradio/ or my WL-520gU talk at NOTACON.
jeroen94704
Posts: 109
Joined: Sat Feb 13, 2010 4:27 am
Location: Eindhoven, the Netherlands

Re: interface.sh not starting at boot

Postby jeroen94704 » Thu May 24, 2012 3:14 am

Are you maybe changing anything else in the network configuration. Keep in mind that the wifi interface can either be client or access point, but not both at once. How are you connecting your PC to the router? Using a network cable or wirelessly? How does the router connect to the internet? Using a cable, or wirelessly? What does your network configuration on the router look like?

While I've learned to never say "impossible" when it comes to computers, it strikes me as unlikely the interface.sh script is responsible for this problem, since it only interacts with the serial port, not the network interfaces.

Jeroen

janur55
Posts: 7
Joined: Sun Nov 06, 2011 4:22 pm

Re: interface.sh not starting at boot

Postby janur55 » Thu May 24, 2012 5:42 pm

okay,,thanks for reply
i feel strange why if i make it run at boot i can't browse via my pc...i connected via cable to my asus lan port
but if i make chmod ugo-x /etc/init.d/AVR then reboot...i can browse via PC,, so weird
i was change the START command from /etc/init.d/AVR from 40,10 but it actually not show the change..so i make it default again

here my configuration

/etc/config/network

Code: Select all

#### VLAN configuration
config switch eth0
   option vlan0   "1 2 3 4 5*"
   option vlan1   "0 5"


#### Loopback configuration
config interface loopback
   option ifname   "lo"
   option proto   static
   option ipaddr   127.0.0.1
   option netmask   255.0.0.0


#### LAN configuration
config interface lan
   option type    bridge
   option ifname   "eth0.0"
   option proto   static
   option ipaddr   192.168.0.1
   option netmask   255.255.255.0


#### WAN configuration
config interface   wan
   option ifname   "eth0.1"
   option proto   dhcp


/etc/config/wireless

Code: Select all

config wifi-device  wl0
   option type     broadcom
   option channel  5

   # REMOVE THIS LINE TO ENABLE WIFI:
   # option disabled 1

config wifi-iface
   option device   wl0
   option network   wan
   option mode     sta
   option ssid     "TESTING1"
   option encryption none


/etc/config/firewall

Code: Select all

config defaults
   option syn_flood   1
   option input      ACCEPT
   option output      ACCEPT
   option forward      REJECT

config zone
   option name      lan
   option input   ACCEPT
   option output   ACCEPT
   option forward   REJECT

config zone
   option name      wan
   option input   ACCEPT
   option output   ACCEPT
   option forward   REJECT
   option masq      1

config forwarding
   option src      lan
   option dest     wan


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#   option src      lan
#   option src_ip   192.168.45.2
#   option dest      wan
#   option proto   tcp
#   option target   REJECT

# block a specific mac on wan
#config rule
#   option dest      wan
#   option src_mac   00:11:22:33:44:66
#   option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#   option src      lan
#   option proto   ICMP
#   option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#   option src         wan
#   option src_dport   80
#   option dest         lan
#   option dest_ip      192.168.16.235
#   option dest_port   80
#   option proto      tcp

# include a file with users custom iptables rules
#config include
#   option path /etc/firewall.user


### FULL CONFIG SECTIONS
#config rule
#   option src      lan
#   option src_ip   192.168.45.2
#   option src_mac   00:11:22:33:44:55
#   option src_port   80
#   option dest      wan
#   option dest_ip   194.25.2.129
#   option dest_port   120
#   option proto   tcp
#   option target   REJECT

#config redirect
#   option src      lan
#   option src_ip   192.168.45.2
#   option src_mac   00:11:22:33:44:55
#   option src_port      1024
#   option src_dport   80
#   option dest_ip   194.25.2.129
#   option dest_port   120
#   option proto   tcp

thanks for your help :D