interface.sh not starting at boot

Discussion about my Wifi Radio project at http://mightyohm.com/wifiradio/ or my WL-520gU talk at NOTACON.
User avatar
jasonkunc
Posts: 7
Joined: Thu Sep 23, 2010 10:57 am
Location: Ohio
Contact:

interface.sh not starting at boot

Post by jasonkunc » Wed Sep 29, 2010 7:40 am

The interface.sh script is not starting at boot. I have created the /etc/init.d/AVR file
and created the symbolic link

Code: Select all

ln -s /etc/init.d/AVR /etc/rc.d/S99AVR


the tuner controller potentiometer does not too. I have checked and triple checked the wiring. can someone help?

User avatar
mightyohm
Site Admin
Posts: 1004
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: interface.sh not starting at boot

Post by mightyohm » Mon Oct 04, 2010 10:53 pm

Did you change the script permissions to make it executable?

Show me an 'ls -l' of both the /etc/rc.d and /etc/init.d directories.

The interface.sh script also needs to be executable and in the right place.

bccraig
Posts: 2
Joined: Sat Apr 09, 2011 9:24 am

Re: interface.sh not starting at boot

Post by bccraig » Sat Apr 09, 2011 9:32 am

I'm having the same problem.
ls -l /etc/rc.d

Code: Select all

root@OpenWrt:~# ls -l /etc/rc.d
lrwxrwxrwx    1 root     root           17 Dec  2  2008 K40network -> ../init.d/network
lrwxrwxrwx    1 root     root           16 Dec  2  2008 K99umount -> ../init.d/umount
lrwxrwxrwx    1 root     root           15 Dec  2  2008 S02nvram -> ../init.d/nvram
lrwxrwxrwx    1 root     root           19 Dec  2  2008 S05netconfig -> ../init.d/netconfig
lrwxrwxrwx    1 root     root           14 Dec  2  2008 S10boot -> ../init.d/boot
lrwxrwxrwx    1 root     root           15 Dec  2  2008 S20fstab -> ../init.d/fstab
lrwxrwxrwx    1 root     root           13 Dec  2  2008 S39usb -> ../init.d/usb
lrwxrwxrwx    1 root     root           17 Dec  2  2008 S40network -> ../init.d/network
lrwxrwxrwx    1 root     root           18 Dec  2  2008 S45firewall -> ../init.d/firewall
lrwxrwxrwx    1 root     root           14 Dec  2  2008 S50cron -> ../init.d/cron
lrwxrwxrwx    1 root     root           18 Dec  2  2008 S50dropbear -> ../init.d/dropbear
lrwxrwxrwx    1 root     root           15 Dec  2  2008 S50httpd -> ../init.d/httpd
lrwxrwxrwx    1 root     root           16 Dec  2  2008 S50telnet -> ../init.d/telnet
lrwxrwxrwx    1 root     root           17 Dec  2  2008 S60dnsmasq -> ../init.d/dnsmasq
lrwxrwxrwx    1 root     root           13 Dec  2  2008 S60led -> ../init.d/led
lrwxrwxrwx    1 root     root           15 Jan  1 00:09 S93mpd -> /etc/init.d/mpd
lrwxrwxrwx    1 root     root           14 Dec  2  2008 S95done -> ../init.d/done
lrwxrwxrwx    1 root     root           18 Dec  2  2008 S97watchdog -> ../init.d/watchdog
lrwxrwxrwx    1 root     root           15 Jan  1 00:14 S99AVR -> /etc/init.d/AVR
lrwxrwxrwx    1 root     root           16 Dec  2  2008 S99sysctl -> ../init.d/sysctl


and ls -l /etc/init.d

Code: Select all

root@OpenWrt:~# ls -l /etc/init.d
-rw-r--r--    1 root     root          166 Jan  1 00:09 AVR
-rwxr-xr-x    1 root     root         1756 Oct  4  2008 boot
-rwxr-xr-x    1 root     root          281 Dec  2  2008 cron
-rwxr-xr-x    1 root     root         6196 Dec  2  2008 dnsmasq
-rwxr-xr-x    1 root     root          243 Oct  4  2008 done
-rwxr-xr-x    1 root     root         1176 Dec  2  2008 dropbear
-rwxr-xr-x    1 root     root          178 Dec  2  2008 firewall
-rwxr-xr-x    1 root     root         1498 Oct  4  2008 fstab
-rwxr-xr-x    1 root     root         1005 Dec  2  2008 httpd
-rwxr-xr-x    1 root     root         1238 Oct  4  2008 led
-rwxr-xr-x    1 root     root          690 Dec  2  2008 mpd
-rwxr-xr-x    1 root     root         4577 Oct  4  2008 netconfig
-rwxr-xr-x    1 root     root          414 Oct  4  2008 network
-rwxr-xr-x    1 root     root         2040 Dec  2  2008 nvram
-rwxr-xr-x    1 root     root          134 Oct  4  2008 rcS
-rwxr-xr-x    1 root     root          123 Oct  4  2008 sysctl
-rwxr-xr-x    1 root     root          329 Dec  2  2008 telnet
-rwxr-xr-x    1 root     root           99 Oct  4  2008 umount
-rwxr-xr-x    1 root     root          154 Oct  4  2008 usb
-rwxr-xr-x    1 root     root          140 Oct  4  2008 watchdog


After boot up, I can exicute interface.sh and everything works fine.

User avatar
mightyohm
Site Admin
Posts: 1004
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: interface.sh not starting at boot

Post by mightyohm » Sat Apr 09, 2011 10:31 am

You need to make /etc/init.d/AVR executable.

chmod ugo+x /etc/init.d/AVR should do it.

bccraig
Posts: 2
Joined: Sat Apr 09, 2011 9:24 am

Re: interface.sh not starting at boot

Post by bccraig » Sat Apr 09, 2011 4:12 pm

Ok, I did that but now it seems mpd is not starting at boot, I believe it was before.

ls -l /etc/init.d

Code: Select all

root@OpenWrt:~# ls -l /etc/init.d
-rwxr-xr-x    1 root     root          167 Jan  1 00:05 AVR
-rwxr-xr-x    1 root     root         1756 Oct  4  2008 boot
-rwxr-xr-x    1 root     root          281 Dec  2  2008 cron
-rwxr-xr-x    1 root     root         6196 Dec  2  2008 dnsmasq
-rwxr-xr-x    1 root     root          243 Oct  4  2008 done
-rwxr-xr-x    1 root     root         1176 Dec  2  2008 dropbear
-rwxr-xr-x    1 root     root          178 Dec  2  2008 firewall
-rwxr-xr-x    1 root     root         1498 Oct  4  2008 fstab
-rwxr-xr-x    1 root     root         1005 Dec  2  2008 httpd
-rwxr-xr-x    1 root     root         1238 Oct  4  2008 led
-rwxr-xr-x    1 root     root            0 Dec  2  2008 mpd
-rwxr-xr-x    1 root     root         4577 Oct  4  2008 netconfig
-rwxr-xr-x    1 root     root          414 Oct  4  2008 network
-rwxr-xr-x    1 root     root         2040 Dec  2  2008 nvram
-rwxr-xr-x    1 root     root          134 Oct  4  2008 rcS
-rwxr-xr-x    1 root     root          123 Oct  4  2008 sysctl
-rwxr-xr-x    1 root     root          329 Dec  2  2008 telnet
-rwxr-xr-x    1 root     root           99 Oct  4  2008 umount
-rwxr-xr-x    1 root     root          154 Oct  4  2008 usb
-rwxr-xr-x    1 root     root          140 Oct  4  2008 watchdog

jeroen94704
Posts: 109
Joined: Sat Feb 13, 2010 4:27 am
Location: Eindhoven, the Netherlands

Re: interface.sh not starting at boot

Post by jeroen94704 » Sun Apr 10, 2011 10:29 pm

Looks like you emptied your mpd script, as it's 0 bytes in size. This has nothing to do with the chmod action.

Jeroen

User avatar
mightyohm
Site Admin
Posts: 1004
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: interface.sh not starting at boot

Post by mightyohm » Thu Apr 14, 2011 12:03 am

Jeroen,

Thanks for responding, I appreciate your help on this forum.

bccraig - any luck?

janur55
Posts: 7
Joined: Sun Nov 06, 2011 4:22 pm

Re: interface.sh not starting at boot

Post by janur55 » Mon May 21, 2012 10:26 pm

if i run this script i can't ping from my PC to the internet, i just can ping from my router

what should i do?...i dont want to make it for wifi radio only, but also for my home network

thanks

User avatar
mightyohm
Site Admin
Posts: 1004
Joined: Fri Apr 03, 2009 10:29 pm
Location: Seattle, WA
Contact:

Re: interface.sh not starting at boot

Post by mightyohm » Tue May 22, 2012 5:56 pm

I'm not sure I understand what you are trying to do. Can you please explain?

janur55
Posts: 7
Joined: Sun Nov 06, 2011 4:22 pm

Re: interface.sh not starting at boot

Post by janur55 » Wed May 23, 2012 4:33 pm

okay :D
if i make interface.sh run at boot, i can't browse any web via my PC connected to asus wifi radio,,but if i don't make it run at boot i can browse any web via asus wifi radio.
what's the problem?
thanks

Post Reply