WL-520GU on Linksys WRT54G with DD-WRT

Discussion about my Wifi Radio project at http://mightyohm.com/wifiradio/ or my WL-520gU talk at NOTACON.
Post Reply
nagyg
Posts: 6
Joined: Fri Sep 10, 2010 6:43 am

WL-520GU on Linksys WRT54G with DD-WRT

Post by nagyg »

I have followed Tinkernut's instruction to set up the WifiRadio server on the WL-520GU but it won't connect to the Internet (pinging, opkg update does not work and returns a "bad address" response). When I connect the WAN port of the WL-520GU to the WRT54G via Ethernet cable it works. What do I need to do on the WRT54G so this works?

Here are the settings I have on the WL-520GU:

#### VLAN configuration
config switch eth0
option vlan0 "1 2 3 4 5*"
option vlan1 "0 5"


#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0


#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 192.168.1.176
option netmask 255.255.255.0
option getway 192.168.1.1
option dns 8.8.8.8
- /etc/config/network 1/28 3%

and:

root@OpenWrt:~# vi /etc/config/wireless
config wifi-device wl0
option type broadcom
option channel 5

# REMOVE THIS LINE TO ENABLE WIFI:
# option disabled 1

config wifi-iface
option device wl0
option network lan
option mode sta
option ssid GN
option encryption WEP
option key <my network key>
nagyg
Posts: 6
Joined: Fri Sep 10, 2010 6:43 am

Re: WL-520GU on Linksys WRT54G with DD-WRT

Post by nagyg »

I did everything again from the start and when I try to update opkg this is the error I got back:

root@OpenWrt:~# opkg update
Downloading http://mightyohm.com/files/kamikaze-2.4 ... ackages.gz
wget: bad address 'mightyohm.com'
Signiture check for snapshots skipped because GPG support was not enabled in this build
Collected errors:
* opkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp -P /tmp/opkg-AHhxZv http://mightyohm.com/files/kamikaze-2.4 ... ackages.gz'
nagyg
Posts: 6
Joined: Fri Sep 10, 2010 6:43 am

Re: WL-520GU on Linksys WRT54G with DD-WRT

Post by nagyg »

Plugged my laptop into the ASUS and it can connect to the Internet just fine. I opened a CMD line in Windows XP and I could ping Yahoo.com - no problem. But puttying into the ASUS and pinging Yahoo.com or trying opkg update I get the problem I have described above.
jeroen94704
Posts: 109
Joined: Sat Feb 13, 2010 4:27 am
Location: Eindhoven, the Netherlands

Re: WL-520GU on Linksys WRT54G with DD-WRT

Post by jeroen94704 »

A lot depends on your specific network/wireless setup. Perhaps looking at my config is helpful for you:

/etc/config/network:

Code: Select all

config 'switch' 'eth0'

config 'interface' 'loopback'
option 'ifname' 'lo'
option 'proto' 'static'
option 'ipaddr' '127.0.0.1'
option 'netmask' '255.0.0.0'

config 'interface' 'lan'
option 'type' 'bridge'
option 'ifname' 'eth0.0'
option 'proto' 'dhcp'

config 'interface' 'wan'
option 'ifname' 'eth0.1'
option 'proto' 'dhcp'

config 'interface' 'wlan'
option 'proto' 'dhcp'
option 'type' 'bridge'
option 'ifname' 'wl0'
option 'defaultroute' '0'
option 'peerdns' '0'

config 'switch_vlan' 'eth0_0'
option 'device' 'eth0'
option 'vlan' '0'
option 'ports' '1 2 3 4 5'

config 'switch_vlan' 'eth0_1'
option 'device' 'eth0'
option 'vlan' '1'
option 'ports' '0 5'
/etc/config/wireless:

Code: Select all

config 'wifi-device' 'wl0'
option 'type' 'broadcom'
option 'channel' '5'
option 'disabled' '0'

config 'wifi-iface'
option 'device' 'wl0'
option 'mode' 'sta'
option 'encryption' 'psk'
option 'key' '<mykey>'
option 'ssid' '<myssid>'
option 'network' 'wlan'
nagyg
Posts: 6
Joined: Fri Sep 10, 2010 6:43 am

Re: WL-520GU on Linksys WRT54G with DD-WRT

Post by nagyg »

THANKS!!!!!!!!!!!! It seems to be working now (I'm still waiting for the USB sound card) :D
User avatar
ozBillo
Posts: 8
Joined: Sat Jun 26, 2010 2:24 am
Location: Melbourne, Australia

Re: WL-520GU on Linksys WRT54G with DD-WRT

Post by ozBillo »

hi nagyg,

what did you change to solve your problem? i'm in the same boat :)

cheers,
bill
Post Reply